FAQ: Why do I receive Failed to Connect to Engine? - LogMeIn Help

  Search  
Product:
 
Articles
 
Links
 
Documentation
 
Videos
        
  

Why do I receive Failed to Connect to Engine?

The error "Failed to connect to engine" is caused by the LogMeIn Hamachi Tunneling Engine either failing to start, being in an error state, or being blocked by anti-virus software.

Engine not running properly

To find the status of the engine:

  1. Press the Windows key and the [R] key on the keyboard.
  2. In the run box type services.msc, and press [Enter].
  3. Look for the LogMeIn Hamachi Tunneling Engine.

If the engine is in any of the following states:

  • Started
  • Starting
  • Stopping

Then try restarting either the service, or the entire computer.

On all OS other than Windows 64 bit, if the service is not running or you receive an error upon start-up, check the following registry location: HKEY_LOCAL_MACHINE\SOFTWARE\LogMeIn Hamachi

On Windows 64 bit, check here: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\LogMeIn Hamachi

There should be a String Value (REG_SZ) labeled EngineConfigDir.  If this is not present, create it by right clicking in the blank space and choosing New > String Value.  You may enter any folder location you desire, and it will create the necessary files there for the engine to run.

Important:
Please use care when accessing the Windows Registry.  Consult with your IT support if you are unsure how to proceed.
 

Blocked by anti-virus

If your anti-virus software is reporting/blocking Hamachi-2-ui.exe, you will need to add an exclusion for the Hamachi-2-ui.exe program.  Please consult your anti-virus software documentation for assistance with adding an exclusion to the allowed list.


8/24/2012 7:38 AM