Welcome to LogMeIn Support!
Reset Search
Search

Article

LogMeIn Backup System Requirements

« Go Back

Information

 
Body

LogMeIn Backup is officially supported on the following Operating Systems. The same minimum requirements apply to both Storage PCs and Source PCs.

  • Microsoft Windows 7, Vista, XP, Server 2003 and 2008 (all including 64-bit); and Windows/Server 2000 (VSS is not supported)
  • You must have a connection to the Internet when performing non-local backups
  • You must have JavaScript enabled in your browser
  • You must have enough disk space to hold the backed up data
Note: Backup cannot backup open files on Windows 2000 and 2000 Server.
Note: Backup is not supported on Windows 8 and 2012.
ProductLogMeIn Backup

Is this article helpful?

 

   



Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255

 

Close X